<div><div class="gmail_quote">On Tue, Feb 7, 2012 at 13:42, Comer Duncan <span dir="ltr">&lt;<a href="mailto:comer.duncan@gmail.com">comer.duncan@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

Hi,<br>
<br>
I have ipython .12 installed on my mac laptop and am using a lot on a<br>
project.  It is quite a useful tool.<br>
<br>
I am wanting to also have installed the development version, but also<br>
want to have .12 installed and safe.  I looked at the instructions for<br>
installing the development version but it seems that if I do that I<br>
will overwrite the current 0.12. Since I need 0.12 for my project I<br>
definitely want to keep it safe but I also really want to be able to<br>
pull occasionally the development version.  Can you guys please tell<br>
me how to have both say .12 and .13-development happily installed but<br>
not clobbering each other?<br></blockquote><div><br></div><div>virtual-env is a popular solution for having more than one version of a package installed, and works fine with IPython.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">


<br>
Sorry if this is a naive question. Just want to be safe and am not<br>
really sure what I am doing.<br>
<br>
Thanks for your help.<br>
<br>
Comer<br>
_______________________________________________<br>
IPython-User mailing list<br>
<a href="mailto:IPython-User@scipy.org">IPython-User@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/ipython-user" target="_blank">http://mail.scipy.org/mailman/listinfo/ipython-user</a><br>
</blockquote></div><br></div>