<br><br><div class="gmail_quote">On Fri, Jul 27, 2012 at 10:53 AM, Matthew Turk <span dir="ltr">&lt;<a href="mailto:matthewturk@gmail.com" target="_blank">matthewturk@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

Hi there,<br>
<br>
I&#39;m trying to set up a custom profile for IPython running on my local<br>
machine under MPI, but I&#39;m running into trouble.  This is with the<br>
released 0.13.  I&#39;d like at startup for a couple commands to be run,<br>
to signal to my Python package that it should expect to be running in<br>
parallel (with MPI).  Unfortunately, I&#39;m not quite getting the<br>
behavior I&#39;d expect, and I think it must be something simple on my end<br>
that I&#39;m not understanding.<br>
<br>
I&#39;ve created a new profile with:<br>
<br>
ipython profile create --profile yt --parallel<br>
<br>
Into the startup directory I&#39;ve placed the normal startup commands --<br>
in this case, the main import for the module I intend to work with --<br>
inside a 00-startup.py file.  I&#39;m able to spawn new notebooks that<br>
start up as I&#39;d expect if I do &quot;ipython notebook --profile=yt&quot;.  So<br>
that seems to work properly.  For starting in parallel, I&#39;ve modified<br>
the generated profile in a few places:<br>
<br>
 * I&#39;ve set c.IPClusterEngines.profile = u&#39;yt&#39; in ipcluster_config.py<br>
 * I&#39;ve changed c.IPClusterEngines.engine_launcher_class to &quot;MPI&quot; in<br>
ipcluster_config.py<br></blockquote><div><br></div><div>Exactly right.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
 * In ipengine_config.py I&#39;ve set c.IPEngineApp.profile = u&#39;yt&#39; (I was<br>
not sure if this was either unnecessary or redundant)<br></blockquote><div><br></div><div>Yes, setting profile in config files is indeed always redundant (both cases, here).</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">


 * In ipengine_config.py I&#39;ve added a startup command in<br>
c.IPEngineApp.startup_command<br></blockquote><div><br></div><div>Re-reading the code, this config was broken when the forked Kernel implementations were merged for 0.13.  </div><div>I think right now it is impossible to trigger startup code on engines in 0.13 or master.</div>

<div>Can you <a href="https://github.com/ipython/ipython/issues/new">open an Issue</a> for this?</div><div><br></div><div>The reason being that Kernels/Shells are shared, but the Application objects are still separate, and that is where this startup config lives.  Ultimately, IPEngineApp should go away, but we aren&#39;t quite there yet.</div>

<div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
In the web notebook launcher, changes to the number of processors is<br>
reflected in what happens when I click on &quot;start&quot;.  And looking at the<br>
output of top/ps I also see that the engines have been launched with<br>
mpiexec as I have requested.  I&#39;m also able to connect to them and<br>
verify that they have been launched, but running &quot;dir()&quot; doesn&#39;t show<br>
the expected imports, from the startup_command.  I&#39;m also unable to<br>
get anything to be run if I set c.MPI.init_script to be an existing<br>
script.  Am I missing something with how to set up the configuration?<br>
<br>
Thanks for any ideas,<br>
<br>
Matt<br>
_______________________________________________<br>
IPython-User mailing list<br>
<a href="mailto:IPython-User@scipy.org">IPython-User@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/ipython-user" target="_blank">http://mail.scipy.org/mailman/listinfo/ipython-user</a><br>
</blockquote></div><br>