<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Hi,<div><br></div><div>Which version/ OS/ fronted ?</div><div><br></div><div>I have one notebook that use&nbsp;</div><div><br></div><div>matplotlib.rcParams['text.usetex']=True</div><div><br></div><div>For a long time now, always using dev, and I never had to restart the kernel, at least not for plotting…</div><div>Are your figures really complex ?&nbsp;</div><div>Any chance you can share a minimal reproducible example&nbsp;?</div><div><br></div><div>you can also look at&nbsp;</div><div><a href="https://github.com/ipython/ipython/issues/1198">https://github.com/ipython/ipython/issues/1198</a></div><div><br></div><div>For example to try to increase heartbeat, see if it fixes the problem.</div><div>--&nbsp;</div><div>Matthias</div><div><br></div><div><br></div><div><div><div>Le 2 août 2012 à 11:35, Jeffrey Spencer a écrit :</div><br class="Apple-interchange-newline"><blockquote type="cite">I've noticed that if I enable in matplotlibrc or just interactively set the rcparam for:<div>text.usetex : True<div><br></div><div>Then plot a couple figures. The&nbsp;kernel&nbsp;just keeps asking to restart. If I hit no, then continue working it appears everything is fine and operates flawlessly but will just keep asking every 5 or 10 seconds until I hit restart. If disabled I can have a session going for days no problems.</div>

</div><div><br></div><div>Anyone have any ideas why this is&nbsp;occurring&nbsp;or how to debug further.</div><div><br></div><div>It usually starts when I try to plot and not necessarily the first figure but usually relatively quickly I have to restart. Within 20 minutes of starting that kernal.</div>

<div><br></div><div>Cheers</div>
_______________________________________________<br>IPython-User mailing list<br><a href="mailto:IPython-User@scipy.org">IPython-User@scipy.org</a><br>http://mail.scipy.org/mailman/listinfo/ipython-user<br></blockquote></div><br></div></body></html>