<html>
<head>
<style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 10pt;
font-family:Tahoma
}
--></style></head>
<body class='hmmessage'><div dir='ltr'>
Ok, I try to install ipython 0.13.1 but I got:&nbsp;<div><br><div><br></div><div><div><span style="font-size: 10pt; ">fxdeva11:[~] $ easy_install ipython==0.13.1</span></div><div>Searching for ipython==0.13.1</div><div>Best match: ipython 0.13.1</div><div>Processing ipython-0.13.1-py2.6.egg</div><div>Removing ipython 0.10.1 from easy-install.pth file</div><div>Adding ipython 0.13.1 to easy-install.pth file</div><div>Installing ipcontroller script to /home/user/.local/bin</div><div>Installing iptest script to /home/user/.local/bin</div><div>Installing ipcluster script to /home/user/.local/bin</div><div>Installing ipython script to /home/user/.local/bin</div><div>Installing pycolor script to /home/user/.local/bin</div><div>Installing iplogger script to /home/user/.local/bin</div><div>Installing irunner script to /home/user/.local/bin</div><div>Installing ipengine script to /home/user/.local/bin</div><div><br></div><div>Using /home/user/jding/lib/python2.6/site-packages/ipython-0.13.1-py2.6.egg</div><div>Processing dependencies for ipython==0.13.1</div><div>Finished processing dependencies for ipython==0.13.1</div><div><br></div><div>$ ipython</div><div>Traceback (most recent call last):</div><div>&nbsp; File "/home/user/usr/bin/ipython", line 26, in &lt;module&gt;</div><div>&nbsp; &nbsp; import IPython.Shell</div><div>ImportError: No module named Shell</div><div><br></div><div>Any help will be appreciated.&nbsp;</div><div><br></div><div>thanks</div><div><br></div><br><div><div id="SkyDrivePlaceholder"></div>&gt; From: asmeurer@gmail.com<br>&gt; Date: Wed, 24 Oct 2012 20:04:33 -0600<br>&gt; To: ipython-user@scipy.org<br>&gt; Subject: Re: [IPython-User] error of install ipython 0.10.0<br>&gt; <br>&gt; IPython 0.10.1 is *way* old.  You should be installing IPython 0.13.1.<br>&gt; <br>&gt; With that being said, I don't see any errors in what you pasted.<br>&gt; <br>&gt; Aaron Meurer<br>&gt; <br>&gt; On Wed, Oct 24, 2012 at 7:52 PM, Jack Bryan &lt;dtustudy68@hotmail.com&gt; wrote:<br>&gt; &gt; Hi,<br>&gt; &gt;<br>&gt; &gt; I am trying to install ipython 0.10.0  on Linux Red Hat 4.4.4-17.<br>&gt; &gt;<br>&gt; &gt; I use instructions on:<br>&gt; &gt;<br>&gt; &gt; $ tar -xzf ipython.tar.gz<br>&gt; &gt; $ cd ipython<br>&gt; &gt; $ python setup.py install<br>&gt; &gt;<br>&gt; &gt; http://ipython.org/ipython-doc/stable/install/install.html<br>&gt; &gt;<br>&gt; &gt; but, I got:<br>&gt; &gt;<br>&gt; &gt; import pkg_resources<br>&gt; &gt;         Zope.Interface: yes<br>&gt; &gt;                Twisted: Not found (required for parallel computing<br>&gt; &gt;                         capabilities)<br>&gt; &gt;               Foolscap: Not found (required for parallel computing<br>&gt; &gt;                         capabilities)<br>&gt; &gt;                OpenSSL: 0.10<br>&gt; &gt;                 sphinx: Not found (required for building documentation)<br>&gt; &gt;               pygments: Not found (required for syntax highlighting<br>&gt; &gt;                         documentation)<br>&gt; &gt;                   nose: Not found (required for running the test suite)<br>&gt; &gt;                pexpect: no (required for running standalone doctests)<br>&gt; &gt; running install<br>&gt; &gt; running build<br>&gt; &gt; running build_py<br>&gt; &gt; running build_scripts<br>&gt; &gt; running install_lib<br>&gt; &gt; running install_scripts<br>&gt; &gt; changing mode of /home/user/usr/bin/ipengine to 755<br>&gt; &gt; changing mode of /home/user/usr/bin/ipcontroller to 755<br>&gt; &gt; changing mode of /home/user/usr/bin/ipcluster to 755<br>&gt; &gt; changing mode of /home/user/usr/bin/ipython to 755<br>&gt; &gt; changing mode of /home/user/usr/bin/ipythonx to 755<br>&gt; &gt; changing mode of /home/user/usr/bin/ipython-wx to 755<br>&gt; &gt; changing mode of /home/user/usr/bin/pycolor to 755<br>&gt; &gt; changing mode of /home/user/usr/bin/irunner to 755<br>&gt; &gt; changing mode of /home/user/usr/bin/iptest to 755<br>&gt; &gt; running install_data<br>&gt; &gt; running install_egg_info<br>&gt; &gt; Removing<br>&gt; &gt; /home/user/usr/lib/python2.6/site-packages/ipython-0.10.1-py2.6.egg-info<br>&gt; &gt; Writing<br>&gt; &gt; /home/user/usr/lib/python2.6/site-packages/ipython-0.10.1-py2.6.egg-info<br>&gt; &gt;<br>&gt; &gt; I have used easy_install  to install nose, sphinx, pexpect, pygments.<br>&gt; &gt;<br>&gt; &gt; Why do I still have this error ?<br>&gt; &gt;<br>&gt; &gt; Thanks<br>&gt; &gt;<br>&gt; &gt;<br>&gt; &gt;<br>&gt; &gt;<br>&gt; &gt; _______________________________________________<br>&gt; &gt; IPython-User mailing list<br>&gt; &gt; IPython-User@scipy.org<br>&gt; &gt; http://mail.scipy.org/mailman/listinfo/ipython-user<br>&gt; &gt;<br>&gt; _______________________________________________<br>&gt; IPython-User mailing list<br>&gt; IPython-User@scipy.org<br>&gt; http://mail.scipy.org/mailman/listinfo/ipython-user<br></div></div></div>                                               </div></body>
</html>