<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><br><div><div>Le 6 mars 2013 à 15:43, Dennis Daniels a écrit :</div><br class="Apple-interchange-newline"><blockquote type="cite">Greetings<br><div><br></div><div>I seek clarification.</div><div><br></div><div>I would like to run the dev version of ipython using python3. However I was told this is not possible.</div><div><a href="http://stackoverflow.com/questions/15229081/installing-from-git-errors-python-setupegg-py-develop">http://stackoverflow.com/questions/15229081/installing-from-git-errors-python-setupegg-py-develop</a></div>

<div><br></div><div>The errors that I received on TRYING to run ipython dev using Python3.2.x appears to confirm that it is not possible to run ipython 1.0 dev pulled from GIT using python3.2x.</div><div><br></div><div>That does surprise me though... could someone explain this rational, please?</div></blockquote><div><br></div><div>Hi Dennis,&nbsp;</div><div><br></div><div>the source code of IPython itself is written in python 2.7,&nbsp;</div><div><br></div><div>We do our best to have as much compatibility with python3 , but the source is not compatible **as is** with python3, it needs to go through the conversion process called 2to3</div><div>you can search on github issue tracker there are extensive discussion on what is both (2 and 3) compatible and what is not.&nbsp;</div><div><br></div><div>We do our best to have as much as possible compatible with both python 2 and 3 but it is not that easy.</div><div><br></div><div>This does not mean that you cannot run the current 1.0-dev using Python3, just that you **have to** go through the install process every time you make a change to the source.</div><div>Or you can apply 2to3 by hand and then modify the source as you wish.</div><div><br></div><div>So to use IPython 1.0-dev with python 3, use `python setup.py install` and **not** setupegg.py nor `python3 ipython.py`</div><div><br></div><div><br></div><div>--&nbsp;</div><div>Matt</div><div><br></div><br><blockquote type="cite">

<div><br></div><div>And if it is true, then the install docs really really need to be clear on this.</div><div><br></div><div>Is there a way to use the GIT Ipython 1.0 dev version with python 3.2.x?</div><div><br></div><div>

many thanks in advance,</div><div>Dennis</div>
_______________________________________________<br>IPython-User mailing list<br><a href="mailto:IPython-User@scipy.org">IPython-User@scipy.org</a><br>http://mail.scipy.org/mailman/listinfo/ipython-user<br></blockquote></div><br></body></html>