Hello,<br><br>I installed version IPython 0.13.1 from source after <br>installing the following packages (from source as well):<br>Qt 4.8.4<br>sip: 4.14.4<br>PyQt4: 4.10<br>pyzmq: 2.2.0.1<br>pygments: 1.6<br>tornado: 2.4.1<br>
mathjax<br>
<br>The commands &#39;Ipython console&#39;, &#39;Ipython notebook&#39; work well.<br>When I invoke &#39;Ipython qtconsole&#39; I obtain the following error:<br><br>--------------------------------------------------------------------------------------------------------------------------------------------------<br>

ipython qtconsole<br>Traceback (most recent call last):<br>  File &quot;/wim/pkg/python/2.7.3/bin/ipython&quot;, line 7, in &lt;module&gt;<br>    launch_new_instance()<br>  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/frontend/terminal/ipapp.py&quot;, line 388, in launch_new_instance<br>

    app.initialize()<br>  File &quot;&lt;string&gt;&quot;, line 2, in initialize<br>  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py&quot;, line 84, in catch_config_error<br>    return method(app, *args, **kwargs)<br>

  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/frontend/terminal/ipapp.py&quot;, line 313, in initialize<br>    super(TerminalIPythonApp, self).initialize(argv)<br>  File &quot;&lt;string&gt;&quot;, line 2, in initialize<br>

  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py&quot;, line 84, in catch_config_error<br>    return method(app, *args, **kwargs)<br>  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/core/application.py&quot;, line 325, in initialize<br>

    self.parse_command_line(argv)<br>  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/frontend/terminal/ipapp.py&quot;, line 308, in parse_command_line<br>    return super(TerminalIPythonApp, self).parse_command_line(argv)<br>

  File &quot;&lt;string&gt;&quot;, line 2, in parse_command_line<br>  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py&quot;, line 84, in catch_config_error<br>    return method(app, *args, **kwargs)<br>

  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py&quot;, line 420, in parse_command_line<br>    return self.initialize_subcommand(subc, subargv)<br>  File &quot;&lt;string&gt;&quot;, line 2, in initialize_subcommand<br>

  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py&quot;, line 84, in catch_config_error<br>    return method(app, *args, **kwargs)<br>  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/config/application.py&quot;, line 352, in initialize_subcommand<br>

    subapp = import_item(subapp)<br>  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/utils/importstring.py&quot;, line 40, in import_item<br>    module = __import__(package,fromlist=[obj])<br>  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/frontend/qt/console/qtconsoleapp.py&quot;, line 56, in &lt;module&gt;<br>

    from IPython.external.qt import QtCore, QtGui<br>  File &quot;/wim/pkg/python/2.7.3/lib/python2.7/site-packages/IPython/external/qt.py&quot;, line 43, in &lt;module&gt;<br>    raise ImportError(&#39;Cannot import PySide &gt;= 1.0.3 or PyQt4 &gt;= 4.7&#39;)<br>

ImportError: Cannot import PySide &gt;= 1.0.3 or PyQt4 &gt;= 4.7<br>------------------------------------------------------------------------------------------------------------------------------------------------------<br>

Do you have any idea how I can remediate this eror?<br>Note that I appended the full path to the Qt/4.8.4/bin directory to the PATH variable and the <br>directory Qt/4.8.4/lib to the LD_LIBRARY_PATH env. variable.<br><br>

Thanks,<br><br>Wim<br><br>