[Numpy-discussion] segfault when pickling PyObject arrays

Paul F. Dubois dubois1 at llnl.gov
Tue Jun 5 13:14:41 CDT 2001


Travis:
Works for me ....using either dump or dumps, load or loads
I used Numeric 20.1.0b1 / Python 2.1 / RedHat 6.2

On Tue, 05 Jun 2001, Tavis Rudd wrote:
> Hi,
> I've been having difficultly pickling arrays with the
> type PyObject using Numeric.  I haven't tried it with
> MA but I assume the same problem exists.
> 
> This script works
> =====================================
> from cPickle import dump, load
> from Numeric import array, PyObject
> 
> def pickleIt(obj, fileName):
>     fp = open(fileName, 'w')
>     dump(obj, fp)
>     fp.close
> 
> def loadIt(fileName):
>     fp = open(fileName, 'r')
>     obj = load(fp)
>     fp.close()
>     return obj
> 
> a = array(['abc', 'def', 'ghi'], PyObject)
> pickleIt(a, 'test.pickle')
> 
> This script segfaults
> ====================================
> #  ... same imports and func defs as above
> b = loadIt()
> print b
> 
> ====================================
> 
> I first noticed this when trying to pickle arrays constructed
> from lists of mx.DateTime objects.
> 
> Numeric 19.1.0
> Python 2.1 final
> Linux 2.2.18
> 
> Is this a reproduceable bug or something unique to my 
> setup?
> Tavis
> 
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion at lists.sourceforge.net
> http://lists.sourceforge.net/lists/listinfo/numpy-discussion




More information about the Numpy-discussion mailing list