[Numpy-discussion] 18.4.1 and need volunteer

Paul F. Dubois paul at pfdubois.com
Tue Mar 27 16:47:19 CST 2001


I found that in 18.4.0 I had missed a couple of spots that needed version
specs to setup.

(2.1b2a requires a version argument to setup; I believe this was an error
and they will fix
 it before 2.1 final, but for now I wanted it to work and it won't hurt as
the information is not used)

I need a volunteer to figure out what changes are needed to make 18.4
compile with Pythons before 2.1. I think all that is needed are some #if's
in the right place and then some logic in the setup to set the appropriate
macro when the python version is too early.  But I don't have time to do it
and the new "bug release" policy for Python will increase the number of
stragglers who don't go to new versions.





More information about the Numpy-discussion mailing list