[Numpy-discussion] NumPy on Mac OS 10.1.5

Jack Jansen Jack.Jansen at oratrix.com
Fri Jul 19 14:17:02 CDT 2002


On vrijdag, juli 19, 2002, at 10:12 , Thomas Biesinger wrote:

> Hi,
>
> when I try to install NumPy on Mac OS X.1.5, it fails on this error:
>
> ....
> cc -bundle -undefined suppress build/temp.darwin-5.5-Power Macintosh-
> 2.1/_numpymodule.o build/temp.darwin-5.5-Power Macintosh-2.1/
> arrayobject.o build/temp.darwin-5.5-Power Macintosh-2.1/ufuncobject.o -
> o build/lib.darwin-5.5-Power Macintosh-2.1/_numpy.so
> /usr/bin/ld: -undefined error must be used when -twolevel_namespace is
> in effect

Thomas,
as of MacOSX 10.1 the link step needs either the -flat_namespace 
option, or the -bundle_loader option.

But: this has been fixed in both Python 2.2.1 and Python 2.3a0 
(the CVS tree). Are you by any chance still running Python 2.2 
(which predates OSX 10.1, and therefore two-level namespaces, 
and therefore the right linker invocations, which distutils 
reads from Python's own Makefile).

If you're running 2.2: please upgrade and try again. If you're 
running 2.2.1 or later: let me know and I'll try and think of 
what questions I should ask you to debug this:-)
--
- Jack Jansen        <Jack.Jansen at oratrix.com>        
http://www.cwi.nl/~jack -
- If I can't dance I don't want to be part of your revolution -- 
Emma Goldman -





More information about the Numpy-discussion mailing list