[Numpy-discussion] numarray via CVS

Todd Miller jmiller at stsci.edu
Fri Oct 4 06:26:05 CDT 2002


  Nils Wagner wrote:


>Hi,
>
>I tried to install numarray via latest CVS. However 
>python setup.py install failed 
>
>This is the output
>
>Src/_ndarraymodule.c:240: warning: `_ndarray_bytestride_set' defined but
>not use                         d
>Src/_ndarraymodule.c:260: warning: `_ndarray_byteoffset_get' defined but
>not use                         d
>Src/_ndarraymodule.c:266: warning: `_ndarray_byteoffset_set' defined but
>not use                         d
>Src/_ndarraymodule.c:288: warning: `_ndarray_aligned_get' defined but
>not used
>Src/_ndarraymodule.c:294: warning: `_ndarray_aligned_set' defined but
>not used
>Src/_ndarraymodule.c:323: warning: `_ndarray_contiguous_get' defined but
>not use                         d
>Src/_ndarraymodule.c:329: warning: `_ndarray_contiguous_set' defined but
>not use                         d
>error: command 'gcc' failed with exit status 1
>
>
>Any suggestion ?
>
>Nils
>
>Nils
>


I'm in the process of merging some new C basetypes into the head of CVS 
so I guess the HEAD has to be considered unstable for the next few days. 
  I work hard to keep the CVS in working order,  but you've caught me in 
the middle of "something big".   For now, I have this advice:

1.  Use numarray-0.3.6 until numarray-0.4 is released.

2. When upgrading numarray, always remove the old version.

3. If you're intereseted in writing extensions, stick with numarray's 
Numeric compatability API.

Todd

-- 
Todd Miller 			jmiller at stsci.edu
STSCI / SSB









More information about the Numpy-discussion mailing list