[Numpy-discussion] why numarray.inputarray?

Tim Hochberg tim.hochberg at cox.net
Tue Feb 10 12:58:02 CST 2004


Todd Miller wrote:

[SNIP]

>Based on your [Colin Williams] input, and Tim Hochberg's earlier comments,  I think we
>should:
>
>1. Clean up the array function by ditching the buffer/sequence keyword
>deprecation code.  buffer has been deprecated long enough.
>
>2. Redefine asarray() as calling array() with copy=1.  Tim's right. 
>It's a better name than inputarray() and we want it for backward
>compatibility anyway.
>
>3. Redefine inputarray() as a non-recommended synonym for asarray(). 
>I'd say deprecate it,  but that's a PITA for anyone already using it.
>
>4. Change the manual to document asarray() as primary and document
>inputarray() as a non-recommended synonym.
>
>Comments?
>
>  
>
Sounds good to me. I've never used the buffer/sequence stuff, so I'm not 
really qualified to opine on that.

-tim





More information about the Numpy-discussion mailing list