[Numpy-discussion] why numarray.inputarray?

Sebastian Haase haase at msg.ucsf.edu
Tue Feb 10 13:21:12 CST 2004


> Todd Miller wrote:
>
> [SNIP]
>
> >Based on your [Colin Williams] input, and Tim Hochberg's earlier
comments,  I think we
> >should:
> >
> >1. Clean up the array function by ditching the buffer/sequence keyword
> >deprecation code.  buffer has been deprecated long enough.
> >
> >2. Redefine asarray() as calling array() with copy=1.  Tim's right.
> >It's a better name than inputarray() and we want it for backward
> >compatibility anyway.
> >
> >3. Redefine inputarray() as a non-recommended synonym for asarray().
> >I'd say deprecate it,  but that's a PITA for anyone already using it.
> >
> >4. Change the manual to document asarray() as primary and document
> >inputarray() as a non-recommended synonym.
> >
> >Comments?
> >
> >
> >
> Sounds good to me. I've never used the buffer/sequence stuff, so I'm not
> really qualified to opine on that.
>
Hi,
I'm using memory mapped array and it sounds quite natural to say
'buffer=memmapSoAndSo'
Are you actually saying that 'sequence' is a synonym for that and the
preferred keyword ?

- Sebastian Haase
UCSF






More information about the Numpy-discussion mailing list