[Numpy-discussion] why numarray.inputarray?

verveer at embl.de verveer at embl.de
Tue Feb 10 14:05:00 CST 2004


> > 2. Redefine asarray() as calling array() with copy=1.  Tim's right.  
> > It's a better name than inputarray() and we want it for backward 
> > compatibility anyway. 
 
In that case a copy is always made, right? You only want a copy when a 
conversion is done, otherwise a reference should be returned. That is the 
current behaviour with 0.8 and so does Numeric, if I recall well. 
 
Peter 
 




More information about the Numpy-discussion mailing list