[Numpy-discussion] why numarray.inputarray?

Todd Miller jmiller at stsci.edu
Wed Feb 11 10:15:46 CST 2004


On Tue, 2004-02-10 at 17:03, verveer at embl.de wrote:
> > > 2. Redefine asarray() as calling array() with copy=1.  Tim's right.  
> > > It's a better name than inputarray() and we want it for backward 
> > > compatibility anyway. 
>  
> In that case a copy is always made, right? You only want a copy when a 
> conversion is done, otherwise a reference should be returned. That is the 
> current behaviour with 0.8 and so does Numeric, if I recall well. 

I misspoke here.  It's correct in CVS.

Thanks,
Todd

>  
> Peter 
>  
> 
> 
> -------------------------------------------------------
> The SF.Net email is sponsored by EclipseCon 2004
> Premiere Conference on Open Tools Development and Integration
> See the breadth of Eclipse activity. February 3-5 in Anaheim, CA.
> http://www.eclipsecon.org/osdn
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/numpy-discussion
-- 
Todd Miller <jmiller at stsci.edu>





More information about the Numpy-discussion mailing list