[Numpy-discussion] numarray 0.8 and MacOSX

Francesc Alted falted at openlc.org
Tue Jan 20 09:45:04 CST 2004


Hi,

I'm trying to compile numarray 0.8 on a MacOSX (Darwin 6.8). The compilation
process seemed to go well, but an error happens when trying to import
numarray:

[falted at ppc-osx2:numarray-0.8]$ python
Python 2.2 (#1, 10/24/02, 16:10:52)
[GCC Apple cpp-precomp 6.14] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import numarray
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/home/users/f/fa/falted/bin-macosx//lib/python/numarray/__init__.py", 
line 11, in ?
    from numarrayall import *
  File 
"/home/users/f/fa/falted/bin-macosx//lib/python/numarray/numarrayall.py", 
line 2, in ?
    from generic import *
  File "/home/users/f/fa/falted/bin-macosx//lib/python/numarray/generic.py", 
line 1030, in ?
    import numarraycore as _nc
  File 
"/home/users/f/fa/falted/bin-macosx//lib/python/numarray/numarraycore.py", 
line 29, in ?
    PyINT_TYPES = {
NameError: name 'bool' is not defined

I know that there are available ports of numarray 0.8 to Darwin, but, for a
series of reasons, I prefer to compile it for myself. Anyone can provide a
hint so as to compile it cleanly?

Thanks,

-- 
Francesc Alted






More information about the Numpy-discussion mailing list