[Numpy-discussion] Counting array elements
Alan G Isaac
aisaac at american.edu
Fri Oct 22 15:14:07 CDT 2004
On 22 Oct 2004, Todd Miller apparently wrote:
> sumAll() would certainly be better.
> Unless there are objections, I'll rename the current sum() method to
> sumAll() and re-write sum() to give a deprecation warning before calling
> sumAll(). Eventually, it'll go away altogether.
Just two thoughts from a new user.
i. I agree that .sumAll is better than the current name
ii. even better, I propose, would be for .sum to take
an axis argument, with default matching the sum function,
and possible value axis="all".
For the transition, the axis argument can be required.
More information about the Numpy-discussion