[Numpy-discussion] Trouble installing numarray on Solaris

Nicolas Pernetty nicopernetty at yahoo.fr
Sat Jul 2 03:35:23 CDT 2005


On Fri, 01 Jul 2005 15:02:44 -0700, "Russell E. Owen"
<rowen at cesmail.net> wrote :

> A user of my application reports that installing numarray 1.3.2 on 
> Solaris using Python 2.3.1 has run into trouble:
> 
>   prompt> python
>   Python 2.3.1 (#1, Sep 30 2003, 20:29:58) [C] on sunos5
>   Type "help", "copyright", "credits" or "license" for more
>   information.
>   >>> import numarray
>   Fatal Python error: Call to API function without first calling
>   import_libnumarray() in Src/_convmodule.c
>   Abort (core dumped)
> 
> I've seen a one or two recent reports of this error when running 
> extension modules, but I've never heard of it happening when simply 
> trying to import numarray.
> 
> Any suggestions?
> 
> -- Russell
> 
> P.S. I do realize that python 2.3.1 is old and should be updated, and
> I  have already suggested it. But it seems a bit unlikely to fix this 
> particular problem.
> 

Hello,

I'm happily using Python and numarray on Solaris 5.8 without any
problems. But it's Python 2.4.1 and numarray 1.3.2.
Maybe it's some sort of incompatibility ? Then you should try to install
older version of numarray...




More information about the Numpy-discussion mailing list