[Numpy-discussion] Another thought on future directions

Chris Barker Chris.Barker at noaa.gov
Fri Mar 11 09:08:28 CST 2005


I've got one more issue that might bear thinking about at this juncture:

Versioning control

One issue that has been brought up in the discussion of using ndarrays 
as an interchange format with other packages is that those packages 
might well become dependent on a particular version of SciPy. For me, 
this brings up the issue that I might well want (or need) to have more 
than one version of SciPy installed at once, and be able to select which 
one is used at run time. If nothing else, it facilitates testing as new 
versions come out.

I suggest a system similar to that recently added to wxPython:

import wxversion
wxversion.select("2.5")
import wx

See:

http://wiki.wxpython.org/index.cgi/MultiVersionInstalls

for more details.

Between the wxPython list and others, a lot of pros and cons to doing 
this have been laid out. Honestly, there never really was a consensus 
among the wxPython community, but Robin decided to go for it, and I, for 
one, am very happy with it.


-Chris


-- 
Christopher Barker, Ph.D.
Oceanographer
                                     		
NOAA/OR&R/HAZMAT         (206) 526-6959   voice
7600 Sand Point Way NE   (206) 526-6329   fax
Seattle, WA  98115       (206) 526-6317   main reception

Chris.Barker at noaa.gov




More information about the Numpy-discussion mailing list