[Numpy-discussion] Problem compiling scipy-core

Anoop arajendr at ucsd.edu
Wed Nov 23 15:48:01 CST 2005


Hi. I have problems installing scipy-core from source code on a Rocks
Cluster distribution of Linux running on x86-64 hardware. The error
messages tell me:

/usr/bin/g77 -shared build/temp.linux-x86_64-2.3/scipy/corelib/blasdot/_dotblas.o -L/usr/lib -lblas -lg2c -o build/lib.linux-x86_64-2.3/scipy/lib/_dotblas.so
/usr/bin/ld: skipping incompatible /usr/lib/libblas.so when searching for -lblas
/usr/bin/ld: skipping incompatible /usr/lib/libblas.a when searching for -lblas
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/3.4.4/../../../libblas.so when searching for -lblas
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/3.4.4/../../../libblas.a when searching for -lblas
/usr/bin/ld: skipping incompatible /usr/lib/libblas.so when searching for -lblas
/usr/bin/ld: skipping incompatible /usr/lib/libblas.a when searching for -lblas
/usr/bin/ld: cannot find -lblas
collect2: ld returned 1 exit status


I really need to get this running. Help?

Thanks,
Anoop





More information about the Numpy-discussion mailing list