[Numpy-discussion] Re: compilation error on OSX 10.4

Sebastien Maret smaret at umich.edu
Sat Nov 19 10:53:01 CST 2005


Curzio Basso <curzio.basso at gmail.com> writes:

> I get the following error compiling an extension module using numarray
> 1.4.1 on Mac OSX 10.4:
> -----
> building 'fmlio' extension
> gcc-3.3 -fno-strict-aliasing -Wno-long-double -no-cpp-precomp
> -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -DLINUX
> -I/home/basso/usr/include/python -I/sw/include/python2.4 -c
> src/fmlio.cpp -o
> build/temp.darwin-8.3.0-Power_Macintosh-2.4/src/fmlio.o
> In file included from /sw/include/python2.4/numarray/libnumarray.h:17,
>                  from /sw/include/python2.4/numarray/numarray.h:6,
>                  from src/fmlio.h:10,
>                  from src/fmlio.cpp:2:
> /sw/include/python2.4/numarray/nummacro.h:27: error: parse error before `;'
>    token

There is a bug report for this problem:
http://sourceforge.net/tracker/?func=detail&atid=450446&aid=1350954&group_id=1369

The problem has been fixed in FreeBSD:
http://www.freebsd.org/cgi/cvsweb.cgi/ports/math/py-numarray/files/patch-Include::numarray::nummacro.h

Maybe this patch could be applied to numarray ?

Sébastien





More information about the Numpy-discussion mailing list