[Numpy-discussion] Error installing on amd64 Debian-unstable

Angus McMorland a.mcmorland at auckland.ac.nz
Sun Apr 23 17:40:02 CDT 2006


I had no troubles installing numpy and scipy on my 32-bit laptop, but
cannot get numpy to install on my amd64 debian desktop. I've pulled in
the latest svn versions, then run:

$ python setup.py install

Installation seems to run okay (no error messages), but the following
happens:



In [1]: import numpy
import core -> failed:
/usr/lib/python2.3/site-packages/numpy/core/_sort.so: undefined symbol:
PyArray_CompareUCS4
import lib -> failed: module compiled against version 90703 of C-API but
this version of numpy is 90704
import linalg -> failed: module compiled against version 90703 of C-API
but this version of numpy is 90704
import dft -> failed: cannot import name asarray
import random -> failed: 'module' object has no attribute 'dtype'
---------------------------------------------------------------------------
exceptions.ImportError                               Traceback (most
recent call last)

/home/amcmorl/<ipython console>

/usr/lib/python2.3/site-packages/numpy/__init__.py
     47         return NumpyTest().test(level, verbosity)
     48
---> 49     import add_newdocs
     50
     51     if __doc__ is not None:

/usr/lib/python2.3/site-packages/numpy/add_newdocs.py
----> 2 from lib import add_newdoc
      3
      4 add_newdoc('numpy.core','dtype',
      5            [('fields', "Fields of the data-typedescr if any."),
      6             ('alignment', "Needed alignment for this data-type"),

ImportError: cannot import name add_newdoc



Can anyone suggest what I'm doing wrong?

Cheers,

A.
-- 
Angus McMorland
email a.mcmorland at auckland.ac.nz
mobile +64-21-155-4906

PhD Student, Neurophysiology / Multiphoton & Confocal Imaging
Physiology, University of Auckland
phone +64-9-3737-599 x89707

Armourer, Auckland University Fencing
Secretary, Fencing North Inc.




More information about the Numpy-discussion mailing list