[Numpy-discussion] 1.0b4 problem continuted from 1.0b3

kortmann at ideaworks.com kortmann at ideaworks.com
Mon Aug 28 16:35:59 CDT 2006


On 8/25/06, Travis Oliphant <oliphant.travis at ieee.org> wrote:
> kortmann at ideaworks.com wrote:
> > Message: 4
> > Date: Thu, 24 Aug 2006 14:17:44 -0600
> > From: Travis Oliphant <oliphant at ee.byu.edu>
> > Subject: Re: [Numpy-discussion] (no subject)
> > To: Discussion of Numerical Python
> >         <numpy-discussion at lists.sourceforge.net>
> > Message-ID: <44EE0968.1030904 at ee.byu.edu>
> > Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> >
> > kortmann at ideaworks.com wrote:
> >
> >
> >
> > You have a module built against an older version of NumPy.  What modules
> > are being loaded?  Perhaps it is matplotlib or SciPy
> >
>
> You need to re-build matplotlib.  They should be producing a binary that
> is compatible with 1.0b2 (I'm being careful to make sure future releases
> are binary compatible with 1.0b2).
>
> Also, make sure that you remove the build directory under numpy if you
> have previously built a version of numpy prior to 1.0b2.
>
> -Travis
>
>
> -------------------------------------------------------------------------
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job
easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/numpy-discussion
>

Travis I have recompiled everything.  I removed sci py numpy and matplotlib.

I installed the numpy 1.0b4 win32exe, and then installed scipi 0.5 and
then the latest matplotlib 0.87.4

I recieved this error at first, which is a matplot lib error,

C:\Lameness>c:\python23\python templatewindow.py
Traceback (most recent call last):
  File "templatewindow.py", line 7, in ?
    import wxmpl
  File "c:\python23\lib\site-packages\wxmpl.py", line 25, in ?
    import matplotlib.numerix as Numeric
  File "C:\PYTHON23\Lib\site-packages\matplotlib\numerix\__init__.py",
line 74,
in ?
    Matrix = matrix
NameError: name 'matrix' is not defined
,
and then switched matplotlib to use numeric, and i recieve this error once
again

Overwriting info=<function info at 0x02097C30> from scipy.misc.helpmod
(was <fun
ction info at 0x020777F0> from numpy.lib.utils)
Overwriting who=<function who at 0x020971B0> from scipy.misc.common (was
<functi
on who at 0x020776F0> from numpy.lib.utils)
Overwriting source=<function source at 0x02097EB0> from scipy.misc.helpmod
(was
<function source at 0x02077830> from numpy.lib.utils)
RuntimeError: module compiled against version 1000000 of C-API but this
version
of numpy is 1000002
Fatal Python error: numpy.core.multiarray failed to import... exiting.


abnormal program termination


i googled the error and also found this thread but have not found a solution

http://www.mail-archive.com/numpy-discussion@lists.sourceforge.net/msg01700.html

any help?
thanks
-Kenny





More information about the Numpy-discussion mailing list