[Numpy-discussion] (no subject)

Travis Oliphant oliphant at ee.byu.edu
Thu Aug 24 15:17:44 CDT 2006


kortmann at ideaworks.com wrote:

>>On Thursday 24 August 2006 09:50, kortmann at ideaworks.com wrote:
>>
>>
>>>Sorry for my ignorance, but I have not ever heard of or used mingw32.  I
>>>am also using python 2.3.
>>>
>>>
>>http://en.wikipedia.org/wiki/Mingw  explains in detail.
>>
>>
>
>$HOME=C:\Documents and Settings\Administrator
>CONFIGDIR=C:\Documents and Settings\Administrator\.matplotlib
>loaded ttfcache file C:\Documents and
>Settings\Administrator\.matplotlib\ttffont
>.cache
>matplotlib data path c:\python23\lib\site-packages\matplotlib\mpl-data
>backend WXAgg version 2.6.3.2
>Overwriting info=<function info at 0x01FAF3F0> from scipy.misc.helpmod
>(was <fun
>ction info at 0x01F896F0> from numpy.lib.utils)
>Overwriting who=<function who at 0x01FA46B0> from scipy.misc.common (was
><functi
>on who at 0x01F895F0> from numpy.lib.utils)
>Overwriting source=<function source at 0x01FB2530> from scipy.misc.helpmod
>(was
><function source at 0x01F89730> from numpy.lib.utils)
>RuntimeError: module compiled against version 1000000 of C-API but this
>version
>of numpy is 1000002
>Fatal Python error: numpy.core.multiarray failed to import... exiting.
>
>
>abnormal program termination
>
>


You have a module built against an older version of NumPy.  What modules
are being loaded?  Perhaps it is matplotlib or SciPy

-Travis

Travis I tried doing it again with removing scipy and my old version of
numpy.  I also have matplotlib installed.  is there a special way that i
have to go about installing this because of matplotlib?





More information about the Numpy-discussion mailing list