[Numpy-discussion] pickling arrays: numpy 1.0 can't unpickle numpy 1.0.1

Emanuele Olivetti emanuele at relativita.com
Fri Dec 8 09:06:41 CST 2006


Travis E. Oliphant wrote:
> I correct my previous statement.  Yes, this is true.  Pickles generated 
> with 1.0.1 cannot be read by version 1.0
>
> However, pickles generated with 1.0 can be read by 1.0.1.   It is 
> typically not the case that pickles created with newer versions of the 
> code will work with older versions.   I obviously didn't think that was 
> something to be concerned about because it slipped my mind.
>
> Changeset 3411 is the reason where the hasobject member of the data-type 
> object was given more bits (and therefore needed to be saved).
>   
Thank you for the detailed explanation. I can easily upgrade the
central host that collects results from other hosts in order to
be able to read all results (1.0 or 1.0.1).

Emanuele



More information about the Numpy-discussion mailing list