[Numpy-discussion] numpy install on mac os x 10.4

belinda thom bthom at cs.hmc.edu
Sat Dec 30 16:44:33 CST 2006


>> I'm wondering why the os-related file names that easy_install creates
>> have macosx-10.3 in them (as opposed to 10.4), e.g.
>>
>>    creating /Library/Frameworks/Python.framework/Versions/2.4/lib/
>> python2.4/site-packages/numpy-1.0.1-py2.4-macosx-10.3-fat.egg
>>
>> Is this something I should be concerned about?
>
> No.

One of the reasons I was dorking around w/numpy again is because of a  
problem I ran into wrt scipy (this was when I was obtaining both from  
http://www.macpython.org/packages/py24-fat/index.html). Turns out  
that doing:

 >>> import scipy
 >>> scipy.test()

produced:

  Python 2.4.4 (#1, Oct 18 2006, 10:34:39)
  [GCC 4.0.1 (Apple Computer, Inc. build 5341)] on darwin
  Type "help", "copyright", "credits" or "license" for more information.
  history mechanism set up
   >>> from scipy import *
  RuntimeError: module compiled against version 1000002 of C-API but
  this version of numpy is 1000009
  Traceback (most recent call last):
     File "<stdin>", line 1, in ?
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/
  python2.4/site-packages/scipy/io/__init__.py", line 8, in ?
       from numpyio import packbits, unpackbits, bswap, fread, fwrite, \
  ImportError: numpy.core.multiarray failed to import
  >>>

So I decided to try easy_install on both. Interestingly, the  
easy_install removed a sole (non-important) error when running  
numpy.test(), but I can't even get scipy to install into the site- 
packages directory; easy_install fails before it can do that  
(appended below). I am at my wits end.

Advice on a painless way to install scipy on my G5 OS X 10.4.8 mac  
greatly appreciated.

--b


   easy_install ~/Download/scipy-0.5.2.tar
   Processing scipy-0.5.2.tar
   Running scipy-0.5.2/setup.py -q bdist_egg --dist-dir /tmp/ 
easy_install-nO-aHA/scipy-0.5.2/egg-dist-tmp-qKoMO9
   non-existing path in '/private/tmp/easy_install-nO-aHA/scipy-0.5.2/ 
Lib/linsolve': 'tests'
   /Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/ 
site-packages/numpy-1.0.1-py2.4-macosx-10.3-fat.egg/numpy/distutils/ 
system_info.py:401: UserWarning:
       UMFPACK sparse solver (http://www.cise.ufl.edu/research/sparse/ 
umfpack/)
       not found. Directories to search for the libraries can be  
specified in the
       numpy/distutils/site.cfg file (section [umfpack]) or by setting
   <big fat snip>
   creating build/temp.macosx-10.3-fat-2.4/build
   creating build/temp.macosx-10.3-fat-2.4/build/src.macosx-10.3-fat-2.4
   creating build/temp.macosx-10.3-fat-2.4/build/src.macosx-10.3- 
fat-2.4/Lib
   creating build/temp.macosx-10.3-fat-2.4/build/src.macosx-10.3- 
fat-2.4/Lib/fftpack
   creating build/temp.macosx-10.3-fat-2.4/private/tmp/easy_install- 
nO-aHA/scipy-0.5.2/Lib/fftpack
   creating build/temp.macosx-10.3-fat-2.4/private/tmp/easy_install- 
nO-aHA/scipy-0.5.2/Lib/fftpack/src
   compile options: '-DSCIPY_FFTW3_H -I/opt/local/include -Ibuild/ 
src.macosx-10.3-fat-2.4 -I/Library/Frameworks/Python.framework/ 
Versions/2.4/lib/python2.4/site-packages/numpy-1.0.1-py2.4- 
macosx-10.3-fat.egg/numpy/core/include -I/Library/Frameworks/ 
Python.framework/Versions/2.4/include/python2.4 -c'
   gcc: build/src.macosx-10.3-fat-2.4/fortranobject.c
   gcc: /private/tmp/easy_install-nO-aHA/scipy-0.5.2/Lib/fftpack/src/ 
zrfft.c
   gcc: build/src.macosx-10.3-fat-2.4/Lib/fftpack/_fftpackmodule.c
   gcc: /private/tmp/easy_install-nO-aHA/scipy-0.5.2/Lib/fftpack/src/ 
zfftnd.c
   gcc: /private/tmp/easy_install-nO-aHA/scipy-0.5.2/Lib/fftpack/src/ 
drfft.c
   gcc: /private/tmp/easy_install-nO-aHA/scipy-0.5.2/Lib/fftpack/src/ 
zfft.c
   Traceback (most recent call last):
     File "/Library/Frameworks/Python.framework/Versions/Current/bin/ 
easy_install", line 7, in ?
       sys.exit(
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
easy_install.py", line 1588, in main
       with_ei_usage(lambda:
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
easy_install.py", line 1577, in with_ei_usage
       return f()
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
easy_install.py", line 1592, in <lambda>
       distclass=DistributionWithoutHelpCommands, **kw
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/core.py", line 149, in setup
       dist.run_commands()
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/dist.py", line 946, in run_commands
       self.run_command(cmd)
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/dist.py", line 966, in run_command
       cmd_obj.run()
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
easy_install.py", line 211, in run
       self.easy_install(spec, not self.no_deps)
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
easy_install.py", line 427, in easy_install
       return self.install_item(None, spec, tmpdir, deps, True)
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
easy_install.py", line 471, in install_item
       dists = self.install_eggs(spec, download, tmpdir)
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
easy_install.py", line 655, in install_eggs
       return self.build_and_install(setup_script, setup_base)
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
easy_install.py", line 930, in build_and_install
       self.run_setup(setup_script, setup_base, args)
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
easy_install.py", line 919, in run_setup
       run_setup(setup_script, args)
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/ 
sandbox.py", line 26, in run_setup
       DirectorySandbox(setup_dir).run(
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/ 
sandbox.py", line 63, in run
       return func()
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/ 
sandbox.py", line 29, in <lambda>
       {'__file__':setup_script, '__name__':'__main__'}
     File "setup.py", line 55, in ?
     File "setup.py", line 47, in setup_package
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/numpy-1.0.1-py2.4-macosx-10.3-fat.egg/numpy/ 
distutils/core.py", line 174, in setup
       return old_setup(**new_attr)
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/core.py", line 149, in setup
       dist.run_commands()
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/dist.py", line 946, in run_commands
       self.run_command(cmd)
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/dist.py", line 966, in run_command
       cmd_obj.run()
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
bdist_egg.py", line 174, in run
       cmd = self.call_command('install_lib', warn_dir=0)
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
bdist_egg.py", line 161, in call_command
       self.run_command(cmdname)
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/cmd.py", line 333, in run_command
       self.distribution.run_command(command)
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/dist.py", line 966, in run_command
       cmd_obj.run()
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/setuptools-0.6c3-py2.4.egg/setuptools/command/ 
install_lib.py", line 20, in run
       self.build()
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/command/install_lib.py", line 110, in build
       self.run_command('build_ext')
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/cmd.py", line 333, in run_command
       self.distribution.run_command(command)
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/dist.py", line 966, in run_command
       cmd_obj.run()
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/numpy-1.0.1-py2.4-macosx-10.3-fat.egg/numpy/ 
distutils/command/build_ext.py", line 121, in run
       self.build_extensions()
     File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
python2.4/distutils/command/build_ext.py", line 405, in build_extensions
       self.build_extension(ext)
     File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/numpy-1.0.1-py2.4-macosx-10.3-fat.egg/numpy/ 
distutils/command/build_ext.py", line 312, in build_extension
       link = self.fcompiler.link_shared_object
   AttributeError: 'NoneType' object has no attribute  
'link_shared_object'

  
                                           


More information about the Numpy-discussion mailing list