[Numpy-discussion] Matlab page on scipy wiki

Eric Firing efiring at hawaii.edu
Fri Feb 10 14:59:03 CST 2006


Travis Oliphant wrote:
> Christopher Barker wrote:
> 
>> Colin J. Williams wrote:
>>
>>>> numpy.r_[1,0,range(1,5),0,1]
>>>
>>>
>>
>>> This seems to be a neat idea but not in the usual Python style.
>>
>>
>>
>> Exactly. couldn't it at least get a meaningful, but short, name?
> 
> 
> It is meaningful :-)  r_ means row concatenation...  (but, it has taken 
> on more functionality than that).  What name do you suggest?

"cat"?  "rcat"? "catr"?  "catter"?

Eric




More information about the Numpy-discussion mailing list