[Numpy-discussion] numpy 0.9.4 on cygwin

Tariq Mahmood mahmood.tariq at gmail.com
Sun Feb 19 17:58:03 CST 2006


Hi,
Has anyone been successful at installing numpy 0.9.4 on cygwin?

Details:
os.name: posix
uname -a: CYGWIN_NT-5.1
sys.platform: cygwin
sys.version: 2.4.1
numpy.version: 0.9.4

Steps taken:
1. unpacked numpy-0.9.4.tar.gz
2. changed to numpy-0.9.4 directory
3. python setup.py install

Major error messages while compiling C source:

1. undefined reference to `_feclearexcept' in umathmodule
2. Command "gcc -shared -Wl,--enable-auto-image-base
build/temp.cygwin-1.5.18-i686-2.4/build/src/numpy/core/src/umathmodule.o
-L/usr/lib/python2.4/config -lpython2.4 -o
build/lib.cygwin-1.5.18-i686-2.4/numpy/core/umath.dll" failed with
exit status 1

Other information that might be useful:
1. successfully installed both Numeric 24.2 and numarray 1.5.0

Any help would be appreciated.

Tariq




More information about the Numpy-discussion mailing list