[Numpy-discussion] LAPACK Problem with "import numpy" on AIX

Adam Carter adam at epcc.ed.ac.uk
Thu Jul 13 05:02:07 CDT 2006


Hi all,

I'm new to this list so apologies if this is a solved problem, but I haven't
been able to find anything in the archives.

I've just installed Python 2.4.3 and Numpy-0.9.8 on AIX, and the
configure/make/install of Python and the install of Numpy _appeared_ to go
smoothly.

However, now when I run python and type

>>> import numpy

I get 

import linalg -> failed: No module named lapack_lite

I'm not sure if this is just a warning, but I suspect not, as when I later
try import scipy, it results in a traceback:

>>> import scipy
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File
"/hpcx/home/z001/z001/adam/packages/Python-2.4.3/lib/python2.4/site-packages
/scipy/__init__.py", line 34, in ?
    del linalg
NameError: name 'linalg' is not defined

Can anytone tell me what I'm doing wrong? I've not explicitly installed any
LAPACK library but I was hpoing to use an existing (vendor provided) LAPACK.
The environment variable $LAPACK was set to point to this library at compile
and run-time. 

Do I need lapack_lite aswell? Where can I get it? If I need this other
LAPACK, how can I ensure that my code uses the optimised version of LAPACK
already on this system I'm using? 

Any advice very welcome. Thanks in advance,

Adam

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~  
 Dr Adam Carter (Applications Consultant)  |epcc|
 e: adam at epcc.ed.ac.uk  w: http://www.epcc.ed.ac.uk/~adam
 r: 3405 JCMB           t: +44 131 650 6009





More information about the Numpy-discussion mailing list