[Numpy-discussion] problem building Numeric on python 2.5

Sebastian Haase haase at msg.ucsf.edu
Sun Jul 2 12:20:51 CDT 2006


Hi,
It seems that there is a current discussion on python-dev
http://www.gossamer-threads.com/lists/engine?do=post_view_flat;post=497487;page=1;mh=-1;list=python;sb=post_latest_reply;so=ASC

and the warning should go away by 2.5b2
So: don't change any code quite yet ....

Cheers,
-Sebastian Haase

Tim Hochberg wrote:
> Russell E. Owen wrote:
>> I just installed python 2.5b1 on my Mac (10.4 ppc) and can't seem to get 
>> Numeric 24.2 installed. It seems to build fine (no obvious error 
>> messages), but when I try to import it I get:
>> Python 2.5b1 (r25b1:47038M, Jun 20 2006, 16:17:55) 
>> [GCC 4.0.1 (Apple Computer, Inc. build 5341)] on darwin
>> Type "help", "copyright", "credits" or "license" for more information.
>>   
>>>>> import Numeric
>>>>>         
>> __main__:1: ImportWarning: Not importing directory 
>> '/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-pac
>> kages/Numeric': missing __init__.py
>>   
>>
>> Any ideas? Is it somehow incompatible with python 2.5b1?
>>   
> Import warning is a new 'feature' of 2.5. It warns if there are 
> directories on sys.path that are *not* packages. I'll refer you to the 
> py-dev archives if you want figure out the motivation for that. So, if 
> everything seems to work, there's a good chance that nothing's wrong, 
> but that your just seeing a complaint due to this new behaviour. If you 
> check recent messages on Python-dev someone just posted a recipe for 
> suppressing this warning.
> 
> -tim
> 
> 
>> For what it's worth, numarray builds and installs fine. I've not tried 
>> numpy or any other packages yet.
>>
>> -- Russell






More information about the Numpy-discussion mailing list