[Numpy-discussion] LAPACK Problem with "import numpy" on AIX

Adam Carter adam at epcc.ed.ac.uk
Thu Jul 13 05:19:16 CDT 2006



> Lapack_lite is in the numpy sources.  I think it's the fallback if you
don't have a LAPACK.

Thanks Bill, that's what I thought, but I don't understand why it can't find
it. 

> You can check the config that got built with:
> numpy.show_config()

OK, so it appears that NumPy is imported then, albeit with the warning. The
result of the above line is included below.

So maybe the problem lies with SciPy? Perhaps I should take my problem to
scipy-users. Unless anyone has any further insight?

Cheers,

Adam


>>> numpy.show_config()
blas_info:
    libraries = ['blas']
    library_dirs = ['/usr/lib']
    language = f77

lapack_info:
    libraries = ['lapack']
    library_dirs = ['/usr/local/lib']
    language = f77

atlas_threads_info:
  NOT AVAILABLE

blas_opt_info:
    libraries = ['blas']
    library_dirs = ['/usr/lib']
    language = f77
    define_macros = [('NO_ATLAS_INFO', 1)]

atlas_blas_threads_info:
  NOT AVAILABLE

lapack_opt_info:
    libraries = ['lapack', 'blas']
    library_dirs = ['/usr/local/lib', '/usr/lib']
    language = f77
    define_macros = [('NO_ATLAS_INFO', 1)]

atlas_info:
  NOT AVAILABLE

lapack_mkl_info:
  NOT AVAILABLE

blas_mkl_info:
  NOT AVAILABLE

atlas_blas_info:
  NOT AVAILABLE

mkl_info:
  NOT AVAILABLE





More information about the Numpy-discussion mailing list