[Numpy-discussion] problem building Numeric on python 2.5

Russell E. Owen rowen at cesmail.net
Thu Jun 22 17:45:01 CDT 2006


I just installed python 2.5b1 on my Mac (10.4 ppc) and can't seem to get 
Numeric 24.2 installed. It seems to build fine (no obvious error 
messages), but when I try to import it I get:
Python 2.5b1 (r25b1:47038M, Jun 20 2006, 16:17:55) 
[GCC 4.0.1 (Apple Computer, Inc. build 5341)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import Numeric
__main__:1: ImportWarning: Not importing directory 
'/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-pac
kages/Numeric': missing __init__.py
>>> 

Any ideas? Is it somehow incompatible with python 2.5b1?

For what it's worth, numarray builds and installs fine. I've not tried 
numpy or any other packages yet.

-- Russell





More information about the Numpy-discussion mailing list