[Numpy-discussion] Upgrading from numpy 0.9.7.2416 to 0.9.9.2683

Keith Goodman kwgoodman at gmail.com
Tue Jun 27 11:45:57 CDT 2006


This works in numpy 0.9.7.2416 but doesn't work in numpy 0.9.9.2683:

Numpy 0.9.9.2683

x = asmatrix(zeros((3,2), float))
y = asmatrix(rand(3,1))
y

matrix([[ 0.49865026],
       [ 0.82675808],
       [ 0.30285247]])

x[:,1] = y > 0.5
x

matrix([[ 0.,  0.],
       [ 0.,  0.],  <--- this should be one (?)
       [ 0.,  0.]])

But it worked in 0.9.7.2416:

x = asmatrix(zeros((3,2), float))
y = asmatrix(rand(3,1))
y

matrix([[ 0.35444501],
       [ 0.7032141 ],
       [ 0.0918561 ]])

x[:,1] = y > 0.5
x

matrix([[ 0.,  0.],
       [ 0.,  1.],
       [ 0.,  0.]])




More information about the Numpy-discussion mailing list