[Numpy-discussion] Upgrading from numpy 0.9.7.2416 to 0.9.9.2683

Stefan van der Walt stefan at sun.ac.za
Tue Jun 27 13:12:48 CDT 2006


On Tue, Jun 27, 2006 at 09:45:57AM -0700, Keith Goodman wrote:
> This works in numpy 0.9.7.2416 but doesn't work in numpy 0.9.9.2683:
> 
> Numpy 0.9.9.2683
> 
> x = asmatrix(zeros((3,2), float))
> y = asmatrix(rand(3,1))
> y
> 
> matrix([[ 0.49865026],
>        [ 0.82675808],
>        [ 0.30285247]])
> 
> x[:,1] = y > 0.5
> x
> 
> matrix([[ 0.,  0.],
>        [ 0.,  0.],  <--- this should be one (?)
>        [ 0.,  0.]])

With r2691 I see

In [7]: x = N.asmatrix(N.zeros((3,2)),float)

In [8]: y = N.asmatrix(N.rand(3,1))

In [12]: x[:,1] = y > 0.5

In [13]: x
Out[13]:
matrix([[ 0.,  1.],
       [ 0.,  1.],
       [ 0.,  1.]])

Cheers
Stéfan




More information about the Numpy-discussion mailing list