[Numpy-discussion] trouble on tru64

Travis Oliphant oliphant.travis at ieee.org
Thu Jun 29 12:28:05 CDT 2006


N Shimizu wrote:
> Hi everyone,
>
> I tried to build numpy 0.9.8 on compaq alpha tru64 UNIX v5.1 with gcc 4.0.2,
>   
> but I encounterd the compilation trouble.
>   

Thanks for the test.   This looks like a configuration problem.     
Could you post the config.h file that is generated when you run python 
setup.py

It should be found in

build/src.<platform>-<version>/numpy/core/config.h

I don't think we've got the right set of configurations going for that 
platform.    Basically, we need to know if it has certain float and long 
versions of standard math functions (like floorf and floorl). 

It looks like the configuration code detected that it didn't have these 
functions but then during compilation, the functions that NumPy created 
were already defined causing the error.

If we can first get a valid config.h file for your platform, then we can 
figure out how to generate it during build time.

-Travis





More information about the Numpy-discussion mailing list