[Numpy-discussion] SVN version of NumPy will require rebuild of extensions

Travis Oliphant oliphant at ee.byu.edu
Thu Mar 16 13:04:05 CST 2006


This is to serve notice that I altered the C-API table in the SVN 
version of numpy.   This change will require a rebuild of extension 
modules.  

You are supposed to get notice of that when you try to import the 
extension module (but that didn't work for me for some reason, importing 
scipy just segfaulted --- ahh.. I just figured it out... the command 
that gets the version number is located down in the table.  This 
location has just changed.  It makes a case that this command should 
always be the first entry in the C-API table).

The modifications (with a few new C-API calls) will allow construction 
of the scalar-math tables.



-Travis






More information about the Numpy-discussion mailing list