Can' compile numpy 1.02rc3 on OSX 10.3.9

Markus Rosenstihl markusro at element.fkp.physik.tu-darmstadt.de
Thu Nov 2 09:13:34 CST 2006


Hi!
This, and similar problems with other programs were fixed when I  
installed
10.4 SDK from Apple Developer Conenction.
Yes, the 10.4 SDK can be installed on 10.3.9.

Regards
Markus


Am 19.10.2006 um 23:56 schrieb Markus Rosenstihl:

> Hi!
> I try to compile numpy rc3 on Panther and get following errors.
> (I start build with "python2.3 setup.py build" to be sure to use the
> python shipped with OS X. I din't manage to compile Python2.5 either
> yet with similar errors)
> Does anynbody has an Idea?
> gcc-3.3
> XCode 1.5
> November gcc updater is installed
>
>
> regards
>
> Markus
>
> python2.3 setup.py build
> ...
> compile options:
> '-Ibuild/src.darwin-7.9.0-Power_Macintosh-2.3/numpy/core/src
> -Inumpy/core/include
> -Ibuild/src.darwin-7.9.0-Power_Macintosh-2.3/numpy/core
> -Inumpy/core/src -Inumpy/core/include
> -I/System/Library/Frameworks/Python.framework/Versions/2.3/include/
> python2.3 -c'
> gcc: numpy/core/src/multiarraymodule.c
> In file included from numpy/core/src/arrayobject.c:511,
>                   from numpy/core/src/multiarraymodule.c:63:
> numpy/core/src/arraytypes.inc.src: In function `LONGDOUBLE_scan':
> numpy/core/src/arraytypes.inc.src:883: warning: long double format,
> npy_longdouble arg (arg 3)
> gcc -Wl,-F. -Wl,-F. -bundle -framework Python
> build/temp.darwin-7.9.0-Power_Macintosh-2.3/numpy/core/src/
> multiarraymodule.o -o
> build/lib.darwin-7.9.0-Power_Macintosh-2.3/numpy/core/multiarray.so
> ld: Undefined symbols:
> _fstatvfs referenced from Python expected to be defined in libSystem
> _lchown referenced from Python expected to be defined in libSystem
> _statvfs referenced from Python expected to be defined in libSystem
> ld: Undefined symbols:
> _fstatvfs referenced from Python expected to be defined in libSystem
> _lchown referenced from Python expected to be defined in libSystem
> _statvfs referenced from Python expected to be defined in libSystem
> error: Command "gcc -Wl,-F. -Wl,-F. -bundle -framework Python
> build/temp.darwin-7.9.0-Power_Macintosh-2.3/numpy/core/src/
> multiarraymodule.o -o
> build/lib.darwin-7.9.0-Power_Macintosh-2.3/numpy/core/multiarray.so"
> failed with exit status 1
>
>
> ----------------------------------------------------------------------- 
> --
> Using Tomcat but need to do more? Need to support web services,  
> security?
> Get stuff done quickly with pre-integrated technology to make your job  
> easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache  
> Geronimo
> http://sel.as-us.falkag.net/sel? 
> cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/numpy-discussion


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642




More information about the Numpy-discussion mailing list