problems installing NumPy on OSX

arildna at stud.ntnu.no arildna at stud.ntnu.no
Sat Nov 4 16:32:10 CST 2006


Siterer Robert Kern <robert.kern at gmail.com>:

> arildna at stud.ntnu.no wrote:
>> Hi,
>>
>> I'm sorry if this might seem like a stupid question to some of you,
>> but I have been struggling for the better part of the afternoon trying
>> to install NumPy on my G4 iBook, so I hope somebody can take the time
>> to lend me a helping hand. I have searched a little in the mail
>> archives and tried to follow the instructions on this page:
>> http://www.scipy.org/Installing_SciPy/Mac_OS_X
>
> Note that these are instructions for installing scipy, so there is a  
>  lot there
> that you don't need to do just to install numpy. Notably, some of the things
> that you are having problems with.

I did get the impression that it was kind of an overkill...

>> After that I didn't really expect the installation of NumPy to work,
>> but I got a "permission denied"-error message that I'm not so sure is
>> connected to the missing FFW.
>
> You probably tried to run a previous build or install as root.   
> Delete the build/
> directory (probably as root) and try another build as a regular   
> user. Don't use
> root until you actually want to install (and then, only if you need to).

That got the installation a lot further, but it still halts with an  
error message, this time about failing to test the configuration.

    Arild Næss


==========================================================================

% python setup.py build

Running from numpy source directory.
F2PY Version 2_3396
blas_opt_info:
   FOUND:
     extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
     define_macros = [('NO_ATLAS_INFO', 3)]
     extra_compile_args = ['-faltivec',  
'-I/System/Library/Frameworks/vecLib.framework/Headers']

lapack_opt_info:
   FOUND:
     extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
     define_macros = [('NO_ATLAS_INFO', 3)]
     extra_compile_args = ['-faltivec']

running build
running config_fc
running build_src
building py_modules sources
creating build
creating build/src.macosx-10.3-fat-2.5
creating build/src.macosx-10.3-fat-2.5/numpy
creating build/src.macosx-10.3-fat-2.5/numpy/distutils
building extension "numpy.core.multiarray" sources
creating build/src.macosx-10.3-fat-2.5/numpy/core
Generating build/src.macosx-10.3-fat-2.5/numpy/core/config.h
customize NAGFCompiler
customize AbsoftFCompiler
customize IbmFCompiler
Could not locate executable g77
Could not locate executable f77
Could not locate executable gfortran
Could not locate executable f95
customize GnuFCompiler
customize Gnu95FCompiler
customize G95FCompiler
customize GnuFCompiler
customize Gnu95FCompiler
customize NAGFCompiler
customize NAGFCompiler using config
C compiler: gcc -arch ppc -arch i386 -isysroot  
/Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -Wno-long-double  
-no-cpp-precomp -mno-fused-madd -fno-common -dynamic -DNDEBUG -g -O3

compile options:  
'-I/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5  
-Inumpy/core/src -Inumpy/core/include  
-I/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5  
-c'
gcc: _configtest.c
gcc: cannot specify -o with -c or -S and multiple compilations
gcc: cannot specify -o with -c or -S and multiple compilations
failure.
removing: _configtest.c _configtest.o
numpy/core/setup.py:50: DeprecationWarning: raising a string exception  
is deprecated
   raise "ERROR: Failed to test configuration"
Traceback (most recent call last):
   File "setup.py", line 89, in <module>
     setup_package()
   File "setup.py", line 82, in setup_package
     configuration=configuration )
   File "/Users/arildnss/Desktop/numpy-1.0/numpy/distutils/core.py",  
line 174, in setup
     return old_setup(**new_attr)
   File  
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/distutils/core.py", line 151, in  
setup
     dist.run_commands()
   File  
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/distutils/dist.py", line 974, in  
run_commands
     self.run_command(cmd)
   File  
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/distutils/dist.py", line 994, in  
run_command
     cmd_obj.run()
   File  
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/distutils/command/build.py", line 112, in  
run
     self.run_command(cmd_name)
   File  
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/distutils/cmd.py", line 333, in  
run_command
     self.distribution.run_command(command)
   File  
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/distutils/dist.py", line 994, in  
run_command
     cmd_obj.run()
   File  
"/Users/arildnss/Desktop/numpy-1.0/numpy/distutils/command/build_src.py", line  
87, in run
     self.build_sources()
   File  
"/Users/arildnss/Desktop/numpy-1.0/numpy/distutils/command/build_src.py", line  
106, in build_sources
     self.build_extension_sources(ext)
   File  
"/Users/arildnss/Desktop/numpy-1.0/numpy/distutils/command/build_src.py", line  
212, in build_extension_sources
     sources = self.generate_sources(sources, ext)
   File  
"/Users/arildnss/Desktop/numpy-1.0/numpy/distutils/command/build_src.py", line  
270, in generate_sources
     source = func(extension, build_dir)
   File "numpy/core/setup.py", line 50, in generate_config_h
     raise "ERROR: Failed to test configuration"
ERROR: Failed to test configuration


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642




More information about the Numpy-discussion mailing list