problems installing NumPy on OSX

Steve Lianoglou lists.steve at arachnedesign.net
Sun Nov 5 13:26:49 CST 2006


> I'm sorry, I was a tad too quick typing there. I meant to say "And do
> I even need to [install Xcode] to run numpy?" Robert pointed out that
> a lot things mentioned in the install guide were necessary to run
> scipy, but that you could run numpy without them.
>
> Therefore I was wondering if installing the newest Xcode package was
> likely to fix the error message I am now getting when trying to
> install numpy:

I think Robert may have suggested to install the newest XCode because  
it will give you a newer gcc that can have a better chance compiling  
numpy correctly (or at least will remove another "unkown" to help  
find your true problem).

Maybe there'd be some "Universal Binary-aware"ness that the old xcode  
gcc might be missing that you'll get w/ the new one and since Python  
2.5 is universal, this might be it. Getting the new xcode would be  
the simplest part of the install anyway, so .. why not :-)

-steve



-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642




More information about the Numpy-discussion mailing list