[Numpy-discussion] FAQ: compatibility - scipy, matplotlib, enthought tool suite

Gary pajer at iname.com
Mon Nov 20 19:06:51 CST 2006


I know this has been (mostly) asked and answered, but I'm still not 
certain.  I've been living with an "old" but compatible set of numpy and 
scipy (numpy 1.0 beta) and an older matplotlib.  I decided to try 
Enthought Tool Suite but it fails with a "numpy.core.multiarray failed 
to import".   I could ask on a Enthought list, but I'd like to nail down 
the numpy issue first.

Please forgive me for being dense, and for posting in what might  be the 
wrong place.

True or False:
The latest scipy Win32 binary (0.5.1) *requires* numpy 1.0 rc2
The latest matplotlib (0.87.7) *requires*  numpy 1.0 final
(hence a working set cannot include the latest versions of mpl and numpy)
ETS 1.1.0 (Windows binary)  requires ... what?   (It doesn't work with 
my numpy beta, but the problem may or may not be numpy)

tia,
gap



More information about the Numpy-discussion mailing list