Installation problem

Charles R Harris charlesr.harris at gmail.com
Thu Oct 19 15:39:55 CDT 2006


On 10/19/06, Tommy Grav <tgrav at mac.com> wrote:
>
> I am on a Mac OS X and are trying to install numpy/scipy/matplotlib
>
> ActivePython 2.4.3 Build 11 (ActiveState Software Inc.) based on
> Python 2.4.3 (#1, Apr  3 2006, 18:07:18)
> [GCC 3.3 20030304 (Apple Computer, Inc. build 1666)] on darwin
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import numpy
> >>> numpy.__version__
> '1.1.2881'
> >>> import scipy
> >>> scipy.__version__
> '0.5.0.2095'
> >>> import pylab
> RuntimeError: module compiled against version 1000002 of C-API but this
> version of numpy is 1000000
>

You need a later version of numpy. The latest is 1000006 so you will
probably need to also recompile both matplotlib and scipy against numpy
latest. This is a recent check that Travis put in to track C-API changes. If
you don't compile your own I don't know what you can do except wait.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/numpy-discussion/attachments/20061019/1a44a47d/attachment-0001.html 
-------------- next part --------------
-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
-------------- next part --------------
_______________________________________________
Numpy-discussion mailing list
Numpy-discussion at lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/numpy-discussion


More information about the Numpy-discussion mailing list