[Numpy-discussion] Numpy fails to build with Python 2.5

William Grant william.grant at ubuntu-au.org
Tue Sep 19 04:23:17 CDT 2006


Hi,

I'm currently attempting to get scipy 0.5.1 into Ubuntu, however it
currently cannot happen as numpy doesn't build with Python 2.5. I note
that changeset 3109
(http://projects.scipy.org/scipy/numpy/changeset/3109#file1) is meant to
give 2.5 compatibility, but it is those bits which seem to break it. The
end of the build log with the errors can be found at
http://people.ubuntu.com.au/~fujitsu/numpy_error.txt.

Has anybody got any ideas on how to fix this? A number of Ubuntu users
want scipy 0.5.1, but that can't happen while it won't build with Python
2.5.

Thanks,

William Grant.




More information about the Numpy-discussion mailing list