[Numpy-discussion] Numpy fails to build with Python 2.5

Andrew Straw strawman at astraw.com
Tue Sep 19 16:44:53 CDT 2006


William Grant wrote:

>Hi,
>
>I'm currently attempting to get scipy 0.5.1 into Ubuntu, however it
>currently cannot happen as numpy doesn't build with Python 2.5. I note
>that changeset 3109
>(http://projects.scipy.org/scipy/numpy/changeset/3109#file1) is meant to
>give 2.5 compatibility, but it is those bits which seem to break it. The
>end of the build log with the errors can be found at
>http://people.ubuntu.com.au/~fujitsu/numpy_error.txt.
>
>Has anybody got any ideas on how to fix this? A number of Ubuntu users
>want scipy 0.5.1, but that can't happen while it won't build with Python
>2.5.
>  
>
AFAIK a number of Ubuntu Dapper users are happily using my .debs with
Python 2.4 available at debs.astraw.com. This includes scipy 0.5.2.dev2197

Where are you getting that Ubuntu requires Python 2.5?




More information about the Numpy-discussion mailing list