[Numpy-discussion] numpy1.0rc and matplotlib-0.87.5

Peter Bienstman Peter.Bienstman at ugent.be
Tue Sep 26 03:20:33 CDT 2006


Hi,

Not sure if this is a numpy or a matplotlib issue, but I can't seem to get 
matplotlib-0.87.5  to work with numpy1.0rc:

Python 2.4.3 (#1, Sep 21 2006, 13:06:42)
[GCC 4.1.1 (Gentoo 4.1.1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from pylab import *
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib64/python2.4/site-packages/pylab.py", line 1, in ?
    from matplotlib.pylab import *
  File "/usr/lib/python2.4/site-packages/matplotlib/pylab.py", line 196, in ?
    import cm
  File "/usr/lib/python2.4/site-packages/matplotlib/cm.py", line 5, in ?
    import colors
  File "/usr/lib/python2.4/site-packages/matplotlib/colors.py", line 33, in ?
    from numerix import array, arange, take, put, Float, Int, where, \
  File "/usr/lib/python2.4/site-packages/matplotlib/numerix/__init__.py", line 
74, in ?
    Matrix = matrix
NameError: name 'matrix' is not defined

This is on an AMD64 platform. I tried removing the build directories of both 
packages, and reinstalling, but that didn't work.

I also posted this to the matplotlib list, but got no reply.

Thanks!

Peter
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 307 bytes
Desc: not available
Url : http://projects.scipy.org/pipermail/numpy-discussion/attachments/20060926/a1d128f6/attachment.bin 


More information about the Numpy-discussion mailing list