[Numpy-discussion] Numpy fails to build with Python 2.5

William Grant william.grant at ubuntu.com.au
Tue Sep 19 16:54:16 CDT 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Andrew Straw wrote:
> William Grant wrote:
> 
>> Hi,
>>
>> I'm currently attempting to get scipy 0.5.1 into Ubuntu, however it
>> currently cannot happen as numpy doesn't build with Python 2.5. I note
>> that changeset 3109
>> (http://projects.scipy.org/scipy/numpy/changeset/3109#file1) is meant to
>> give 2.5 compatibility, but it is those bits which seem to break it. The
>> end of the build log with the errors can be found at
>> http://people.ubuntu.com.au/~fujitsu/numpy_error.txt.
>>
>> Has anybody got any ideas on how to fix this? A number of Ubuntu users
>> want scipy 0.5.1, but that can't happen while it won't build with Python
>> 2.5.
>>  
>>
> AFAIK a number of Ubuntu Dapper users are happily using my .debs with
> Python 2.4 available at debs.astraw.com. This includes scipy 0.5.2.dev2197
> 
> Where are you getting that Ubuntu requires Python 2.5?

Ubuntu 6.10 (currently in development) includes Python 2.5.

William.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFFEGcIrbS+qZ0dQCURAhsLAJwLwZvYabv6IUOWHlmvIaRnQmk69QCeJfOt
xFZp00DLb+/PWtbVjUg99gY=
=D2zA
-----END PGP SIGNATURE-----




More information about the Numpy-discussion mailing list