[Numpy-discussion] Fail to compile Numpy on Cygwin

Pearu Peterson pearu@cens.ioc...
Fri Aug 10 03:23:11 CDT 2007


On Fri, August 10, 2007 11:01 am, Javier Maria Torres (MI/EEM) wrote:
> Hi,
>
> I get the following output when trying to compile the latest Numpy SVN
> snapshot on Cygwin (gcc 3.4.4) and Python (Cygwin-installed, 2.5.1; I
> also have the Windows version installed, this might cause problems?). I
> also include the (meager) site.cfg used. I would appreciate any comment.

In your build command

  python setup.py config --compiler=mingw32 build --compiler=mingw32 install

you are not using cygwin gcc compiler but mingw32. I think you cannot
do this - don't ask why, some time ago I failed to determine the cause.

Anyway, under cygwin just try

  python setup.py build

then it should just pick up cygwin compiler.

Or, execute

  python setup.py config --compiler=mingw32 build --compiler=mingw32 install

from Windows cmd line.

HTH,
Pearu



More information about the Numpy-discussion mailing list