[Numpy-discussion] help! not using lapack

Mathew Yeates myeates@jpl.nasa....
Wed Aug 29 15:15:39 CDT 2007


yes, I get
from numpy.core import _dotblas
ImportError: No module named multiarray

Now what?
uname -a
Linux 2.6.9-55.0.2.EL #1 Tue Jun 12 17:47:10 EDT 2007 i686 athlon i386 
GNU/Linux


Robert Kern wrote:
> Mathew Yeates wrote:
>   
>> Hi
>> When I try
>> import numpy
>> id(numpy.dot) == id(numpy.core.multiarray.dot)
>>
>> I get True. But I have liblapck.a installed in ~/lib and I put the lines
>> [DEFAULT]
>> library_dirs = /home/myeates/lib
>> include_dirs = /home/myeates/include
>>
>> in site.cfg
>> In fact, when I build and run a sytem trace I see that liblapack.a is 
>> being accessed.
>>
>> Any ideas?
>>     
>
> It is possible that you have a linking problem with _dotblas.so. On some
> systems, such a problem will only manifest itself at run-time, not build-time.
> At runtime, you will get an ImportError, which we catch because that's also the
> error one gets if the _dotblas is legitimately absent.
>
> Try importing _dotblas by itself to see the error message.
>
>
> In [8]: from numpy.core import _dotblas
>
>
> Most likely you are missing the appropriate libblas, too, since you don't
> mention it.
>
>   




More information about the Numpy-discussion mailing list