[Numpy-discussion] help! not using lapack

Mathew Yeates myeates@jpl.nasa....
Wed Aug 29 15:35:36 CDT 2007


more info. My blas library has zaxpy defined but not  cblas_zaxpy

Mathew Yeates wrote:
> my site,cfg just is
> [DEFAULT]
> library_dirs = /home/myeates/lib
> include_dirs = /home/myeates/include
>
> python setup.py config gives
> F2PY Version 2_3979
> blas_opt_info:
> blas_mkl_info:
>   libraries mkl,vml,guide not found in /home/myeates/lib
>   NOT AVAILABLE
>
> atlas_blas_threads_info:
> Setting PTATLAS=ATLAS
>   libraries ptf77blas,ptcblas,atlas not found in /home/myeates/lib
>   NOT AVAILABLE
>
> atlas_blas_info:
>   libraries f77blas,cblas,atlas not found in /home/myeates/lib
>   NOT AVAILABLE
>
> blas_info:
>   FOUND:
>     libraries = ['blas']
>     library_dirs = ['/home/myeates/lib']
>     language = f77
>
>   FOUND:
>     libraries = ['blas']
>     library_dirs = ['/home/myeates/lib']
>     define_macros = [('NO_ATLAS_INFO', 1)]
>     language = f77
>
> lapack_opt_info:
> lapack_mkl_info:
> mkl_info:
>   libraries mkl,vml,guide not found in /home/myeates/lib
>   NOT AVAILABLE
>
>   NOT AVAILABLE
>
> atlas_threads_info:
> Setting PTATLAS=ATLAS
>   libraries ptf77blas,ptcblas,atlas not found in /home/myeates/lib
>   libraries lapack_atlas not found in /home/myeates/lib
> numpy.distutils.system_info.atlas_threads_info
>   NOT AVAILABLE
>
> atlas_info:
>   libraries f77blas,cblas,atlas not found in /home/myeates/lib
>   libraries lapack_atlas not found in /home/myeates/lib
> numpy.distutils.system_info.atlas_info
>   NOT AVAILABLE
>
> lapack_info:
>   FOUND:
>     libraries = ['lapack']
>     library_dirs = ['/home/myeates/lib']
>     language = f77
>
>   FOUND:
>     libraries = ['lapack', 'blas']
>     library_dirs = ['/home/myeates/lib']
>     define_macros = [('NO_ATLAS_INFO', 1)]
>     language = f77
>
> running config
>
>
> Robert Kern wrote:
>   
>> Mathew Yeates wrote:
>>   
>>     
>>> oops. sorry
>>> from numpy.core import _dotblas
>>> ImportError: 
>>> /home/myeates/lib/python2.5/site-packages/numpy/core/_dotblas.so: 
>>> undefined symbol: cblas_zaxpy
>>>     
>>>       
>> Okay, yes, that's the problem. liblapack depends on libblas. Make sure that you
>> specify one to use. Follow the directions in site.cfg.example. If you need more
>> help, please tell us what libraries you are using, your full site.cfg and the
>> output of
>>
>>   $ python setup.py config
>>
>>   
>>     
>
>
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion@scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion
>
>   




More information about the Numpy-discussion mailing list