[Numpy-discussion] help! not using lapack

Mathew Yeates myeates@jpl.nasa....
Wed Aug 29 15:52:59 CDT 2007


Thanks Robert
I have a deadline and don't have time to install ATLAS. Instead I'm 
installing clapack. Is this the corrrect thing to do?

Mathew

Robert Kern wrote:
> Mathew Yeates wrote:
>   
>> I'm the one who created libblas.a so I must have done something wrong. 
>> This is lapack-3.1.1.
>>     
>
> No, you didn't do anything wrong, per se, you just built the reference F77 BLAS.
> It's not an accelerated BLAS, so there's no point in using it with numpy.
> There's not way you *can* build it to be an accelerated BLAS.
>
> If you want an accelerated BLAS, try to use ATLAS:
>
>   http://math-atlas.sourceforge.net/
>
> It is possible that your Linux distribution, whatever it is, already has a build
> of it for you.
>
>   




More information about the Numpy-discussion mailing list