[Numpy-discussion] Changing the distributed binary for numpy 1.0.4 for windows ?

Fernando Perez fperez.net@gmail....
Tue Dec 11 19:58:19 CST 2007


On Dec 11, 2007 6:45 PM, Ryan Krauss <ryanlists@gmail.com> wrote:
> Near as I can tell, this is still unresolved for people with non-sse2
> machines.  Is that right?

Yup.  Your more detailed testing seems to confirm the hunch I had at
the weekend workshop that SSE2 is the culprit.  Thanks for the info.

It would be really great if we could somehow resolve this quickly.  I
have a WinXP install under Linux, but it seems to see my CPU as an
Athlon X2, so that won't work.  But I also have an old laptop with a
dual-boot XP that's a PIII (no SSE2, and probably the oldest
reasonable hardware we can expect to support).

If someone can provide me with simple instructions on what needs to be
done to build numpy on that thing, without buying any software, I can
volunteer to run a build script on every release that's PIII-safe.

I know nothing about developing on XP, but I'm willing to install the
necessary tools (if free) to at least get this built, because this is
really an untenable situation.  Auto-crashing isn't really a selling
point for software, even under Windows :)

Cheers,

f


More information about the Numpy-discussion mailing list