[Numpy-discussion] installating numpy 1.0.1 on AIX 5.3 using python 2.5 and xlf v10.1

Hans-Joachim Ehlers HansJoachim.Ehlers@eumetsat....
Fri Feb 23 06:06:28 CST 2007


Given :
AIX 5.3
xlf v10.1
python 2.5 
numpy 1.0.1

Task:
Building/installaing numpy on AIX 5.3 

Problem:
The install process can not determine the IBM Fortran compiler
Running   python   ./numpy/distutils/fcompiler/ibm.py gives pretty much
garbage on the screen and the resolut is 'None' .
So i changed the line in ./numpy/distutils/fcompiler/ibm.py
from
        'version_cmd'  : ["xlf"],
to
        'version_cmd'  : ["xlf -qversion"],

since xlf v10 supports the option where xlf v8 does not.

Now running  python   ./numpy/distutils/fcompiler/ibm.py gives me:

customize IbmFCompiler
Couldn't match compiler version for 'IBM XL Fortran Enterprise Edition
V10.1 for AIX \nVersion: 10.01.0000.0004'
None

Could anybody give me a solution/hint since i do not know what else has
to be changed to make a match. BTW: I am not a python programmer. I just
try to build numpy.

Tia
Hajo



More information about the Numpy-discussion mailing list